Jump to content
feduli

Warum so wenig Fps?

Recommended Posts

feduli

Hallo alle miteinander,

 

Ich habe nun schon sehr vieles selbst ausprobiert und bin langsam ratlos da es auch nur mit Tarkov auftritt.

Ich bekomme seit meinem neuem Rig weniger Fps und das komische dabei ist das meine GPU, CPU nur 50% Auslastung haben.

Mein Rig:

i7 6700 OC 4Ghz

GTX 1660 Super 

16GB DDR4 2133Mhz

Rog Strix B250G Gaming

 

Ingame Einstellung: 1955820712_2020-08-0102-54(0).thumb.png.d179c198433dcbb0bdb2d416e34720a2.png

 

 

 

Ingame Auslastung: 51c682228e38e4271fbcdb8fc6e6cdb5.thumb.jpg.4206b90f443076cc9e33de537135fd90.jpg 

 

(Bild wurde im Offline Modus gemacht)

Ich habe schon DPI Skalierung und tausend andere "Fixes" probiert aber nichts scheint wirklich zu helfen.

Am meistens verwundert mich halt die Auslastung, da dort noch genug Platz noch oben ist aber das Game nicht mehr abrufen will (i guess?)

Energieoptionen sind in Windows auf Hochleistung

Factory ist die einzige Map die normal läuft, weiß echt nicht mehr weiter

LG

Share this post


Link to post
Share on other sites
AmunSeth
Posted (edited)

Da gibts im Forum super liebe Leute, die sich die Mühe gemacht haben, sehr ausührliche Anleitungen / Howto's zu schreiben und viele nützliche Tipps zu geben

So ne "SuFu" ist cool 😎

Das kann dutzende Ursachen haben ...

LG

Edited by AmunSeth

Share this post


Link to post
Share on other sites
AmunSeth
Posted (edited)

Sorry, wirklich einfach nur vergessen ... :/
Ein weiteres Problem "kann" der Monitor sein.

Schau doch mal nach, ob dein Monitor die FPS verträgt, Bzw welche Hz-Zahl der so hat.
Ich würde nun annehmen, du hast lediglich ein Upgrade am PC vorgenommen.
Daran sollte es nun "technisch" nicht liegen, das sollte der eigentlich können. ;)

Der Monitor wird manchmal vergessen.
Wenn du nen passablen 60Hz Monitor hast, kann der gut mit Win & Treibern ...
Problem ist nur, daß deine FPS begrenzt werden (können), je nach OS-/SW-Config

Generell, würde es dann auch erst mal ohnehin ausreichen, mit weniger FPS zu arbeiten, sogar eher von Vorteil.
Aber, dies "kann" ebenfalls eine Ursache sein.

Lieber Gruß

Edited by AmunSeth

Share this post


Link to post
Share on other sites
Donidon

Das einzige was ich ändern würde ist die Texturqualität. Deine Grafikkarte hat nur 6GB, und das reicht in EfT nicht für High. Sieht man auch in deinem Screenshot das die 6GB voll sind. Ist der VRAM auf der Grafikkarte voll, nutzt der Rechner den Arbeitsspeicher für die Grafikkarte mit. Der RAM ist aber so schon langsamer als der VRAM, und dann muss halt alles noch über den PCI Bus in die CPU, über den RAM Controller in den Arbeitsspeicher geschoben werden und hin und her....

CPU Auslastung wirst du nie besonders hoch bekommen, die Zeiten sind lange vorbei. Ich habe ein Spiel das hart, aber wirklich hart CPU limitiert ist, obwohl die CPU absolut am Ende ist, liegt die Auslastung lediglich bei 50%. Ein wenig komisch ist deine GPU Auslastung, die ist doch schon recht gering. Hier limitiert irgend etwas, ich schätze es ist der VRAM. An den Ingame Einstellungen liegt es jedenfalls nicht, noch mehr runter drehen geht ja gar nicht mehr.

@AmunSeth wenn der Monitor ein Grund wäre, dann müsste er schon Vsync an haben damit dieser dann im Falle eines 60Hz Monitors auf 60Hz genagelt wird. Und je nach Vsync Buffeering Einstellung hätte er halt nur nicht mehr oder aber in Schritten 60, 30,15 FPS. Er hat aber kein vsync an, und mit seinen 44 FPS ist das nicht der Grund. Auch ein 60Hz Monitor kann mehr als 60 FPS darstellen, nur dann halt nicht als ganze Bilder sondern als Teilframes mit einem netten Bruch im Bild zwischen jedem Stück. Weniger FPS (unter 100) sind niemals ein Vorteil. Sie führen immer zu Input Lags.

  • Thanks 2
  • Upvote 1

Share this post


Link to post
Share on other sites
AmunSeth
vor 8 Minuten schrieb Donidon:

Auch ein 60Hz Monitor kann mehr als 60 FPS darstellen, nur dann halt nicht als ganze Bilder sondern als Teilframes mit einem netten Bruch im Bild zwischen jedem Stück. Weniger FPS (unter 100) sind niemals ein Vorteil. Sie führen immer zu Input Lags.

Ne ne. ist schon alles klar, ich schrieb ja "kann".
Meiner zB ist das nicht ganz so nice.
Alles "über 100"  ist da eher suboptimal, ich hab das zur Zeit alles auf 75 FPS festgelegt und seitdem geht echt klasse.
Werd das aber selber auch noch mal ein wenig austesten, wie das dann so wird, wenn ich doch noch was höher dreh

Danke ❤️

Share this post


Link to post
Share on other sites
AmunSeth
Posted (edited)

Damit man es auch nachvollziehen kann, hab ich mal eben einen Screenshot von meinen Einstellungen gemacht:

940961529_2020-08-0110-05(1).thumb.png.be5afe5fe597d87007c81cacdaffb349.png

läuft so jedenfalls gut und flüssig.
Bei mir ist's so, daß die GraKa einfach zu schnell, zu viele Daten in den Monitor schaufelt, daß ich dann irgendwann massive Lag's und Desync's hab, wenn ich das auf 120 FPS stelle ...
Hab's aber auch nur ein mal auf 75 gestellt, lief dann und, dann nur noch nach dem Motto, "never touch a running System!" 🤣

Aber ich bin auch leicht masochistisch veranlagt und hab dazu auch noch eine AMD-GraKa 🤣
Ich glaub, beim nächsten mal überleg ich mir das noch mal etwas genauer dann ^.^

Edit:
Die antiposobla ..... antisotropische Filterung (uff ... 😅) hab ich gestern auch nur Spaßeshalber deaktiviert ... werd sie nachher wieder auf "pro Textur" stellen.
Das macht bei mir gar nicht so viel aus, zumindest in der Leistung

Edited by AmunSeth

Share this post


Link to post
Share on other sites
Donidon
Posted (edited)
vor 34 Minuten schrieb AmunSeth:

Bei mir ist's so, daß die GraKa einfach zu schnell, zu viele Daten in den Monitor schaufelt, daß ich dann irgendwann massive Lag's und Desync's hab, wenn ich das auf 120 FPS stelle ...
 

Hast du einen freesync Monitor? Wenn ja, teste das mal mit vsync an. Bei mir läuft EfT dann teils geschmeidiger. Manchmal aber auch nicht... EfT ist halt ein schwieriger Fall.

Freesync ist aber auch so ein schwieriger Fall, bei einigen Monitoren läuft das gut, bei anderen wirklich schlecht. Als nVidia die Freesync Unterstützung endlich in die Treiber gepackt hat, haben die viele Monitore getestet wie gut sie das wirklich können. Die Liste ist im Netz... sollte man rein schauen vor einem Neukauf.

AF solltest du an lassen, ob pro Textur oder einfach an ist wumpe, Hauptsache an. AF beruhigt das Bild enorm. Auch so ein Ding das mir bei keinem Spiel so stark aufgefallen ist wie in EfT.

TAA als AA frisst auch etwas mehr Leistung als das andere Dings was man einstellen kann, aber auch TAA beruhigt nochmal das Bild enorm. Und auch hier... EfT... in anderen Spielen ist der Unterschied nicht im Ansatz so extrem. EfT hat generell ein sehr unruhiges Bild.

EfT hat gerne auch Bugs das die eigenen Grafikeinstellungen nicht geladen werden. Der Bug kommt immer wieder und wird auch immer mal wieder gefixt, und ist kurz danach gerne mal wieder da. Also bei so manch einem Problem hilft einfach in den Optionen auf Speichern drücken damit die eigenen Einstellungen geladen werden.

Würde ich nicht andere Spiele mit Unity Engine kennen die das alle nicht haben, würde ich ja denken das liegt daran.

Edited by Donidon

Share this post


Link to post
Share on other sites
Cman1337
vor 8 Stunden schrieb feduli:

Ingame Einstellung: 1955820712_2020-08-0102-54(0).thumb.png.d179c198433dcbb0bdb2d416e34720a2.png

 

Ich würde mal das TAA aus machen und die Texturen entweder auf Mittel oder High + Texture Streaming stellen, das gibt auf jeden Fall eine spürbare verbesserung. HBAO und SSR kannst du locker auf Mittel stellen das ändert nichts an den Frames.

  • Thanks 1

Share this post


Link to post
Share on other sites
feduli
Posted (edited)

Erst einmal vielen Dank an die vielen Antworten,

Ich habe jetzt mal meine Texture quality auf High/Texture Streaming gestellt und wer hätte es gedacht auf einmal das doppelte an FPS (Hatte schon davor Medium probiert was kaum eine Änderung brachte)

372509260_TarkovAuslastunguncapped.thumb.png.8e6b3ab442f0303dd08aa4de27a15a0e.png

Hier meine neuen Settings für den Screenshot oben: 

2133956801_TarkovSettingsNeu.thumb.png.926be8be8100e1553b34d002c0c05852.png

Wahrscheinlich könnte ich noch mehr rauskitzeln mit AA off und Object LOD aber so passt mir das da mein Monitor sowieso nur 75Hz hat.

Bei der Einstellung "Use only Physical Cores" bin ich mir nicht sicher ob das nun besser ist mit meinem i7 6700 oder nicht da die Meinungen dazu die ich fand 50/50 sind (Momentan auf OFF)

Jetzt besteht nur leider ein neues Problem für mich und zwar auch wenn ich auf 75Fps locke bekomme ich Tearing was manchmal sehr auffällig ist.

VSync probiert aber damit verliere ich teilweise Leistung und droppe oft unter 75Fps (Unlocked war dies nicht der Fall)

Habt ihr dafür noch irgendwelche Vorschläge oder muss ich mich damit abfinden?

LG

Edited by feduli

Share this post


Link to post
Share on other sites
AmunSeth

ich musste beim Prozessor nachgooglen ...
Wenn ich nun richtig liege, hat der eh nur physische Kerne, also kannst das aus lassen.

Zum Monitor.
Was mir öfter mal aufgefallen ist, daß Win gerne mal die Hz-Zahl von monitoren auf 60Hz festlegt, auch wenn diese 75Hz können.
Im Treiber kann man das dann noch festlegen, daß der auf 75 läuft.
VSync sollte dann am besten an sein. (Vsync zieht Leistung, ganz klar, machts aber "flüssiger" ...)
Im Spiel mal austesten.
Ich habs 15FPS höher eingestellt, als halt im Treiber/etc, um die InputLags zu minimieren, die Donidon schon erwähnt hat.
Dem entsprechend kannst das dannn mal austesten und im Spiel dann mal auf 90 stellen ...

Ich kann da nun auch nur nach dem "Trial & Error"-Prinzip vorgehen, so würde ich das zumindest erst mal probieren ...
Also erst mal den Treiber einstellen und dann Step by Step rantasten

Share this post


Link to post
Share on other sites
dertexaner
vor 17 Minuten schrieb AmunSeth:

ich musste beim Prozessor nachgooglen ...
Wenn ich nun richtig liege, hat der eh nur physische Kerne, also kannst das aus lassen.

Ich hab ihn jetzt nicht nach gegoogelt aber ich würde mich wundern wenn ein I7 Prozessor keine Threads hat bzw. Mulit (Hyperthreading). Wenn man das verhindern will macht es demnach ab 4 kernen sinn es eingeschaltet zu lassen zumindest es auszuprobieren.

Share this post


Link to post
Share on other sites
AmunSeth
vor 2 Minuten schrieb dertexaner:

Ich hab ihn jetzt nicht nach gegoogelt aber ich würde mich wundern wenn ein I7 Prozessor keine Threads hat bzw. Mulit (Hyperthreading). Wenn man das verhindern will macht es demnach ab 4 kernen sinn es eingeschaltet zu lassen zumindest es auszuprobieren.

hat er. so ist das nicht.
Es macht aber (bisher) nur Faxen, wenn ich Hyper-V als Dienst laufen hab / bzw generell irgendwas virtualisiere oder eine virtuelle Maschine nebenher laufen hab.
Hyper-V muss ich definitiv deaktivieren, wenn ich "EfT" an hab ...
Ich weiß nicht, ob das bei allen der Fall ist (würde nach der Fehlermeldung, die ich bekomme, aber davon ausgehen ^.^)

Daher ja:

vor einer Stunde schrieb feduli:

Bei der Einstellung "Use only Physical Cores" bin ich mir nicht sicher ob das nun besser ist mit meinem i7 6700 oder nicht da die Meinungen dazu die ich fand 50/50 sind (Momentan auf OFF)

Deswegen "Trial & Error"
"ausprobieren" sicher! ✌️

Share this post


Link to post
Share on other sites
feduli
Posted (edited)
vor 52 Minuten schrieb dertexaner:

Ich hab ihn jetzt nicht nach gegoogelt aber ich würde mich wundern wenn ein I7 Prozessor keine Threads hat bzw. Mulit (Hyperthreading). Wenn man das verhindern will macht es demnach ab 4 kernen sinn es eingeschaltet zu lassen zumindest es auszuprobieren.

Laut der offizielen Intel Seite hat mein CPU 4 Kerne, 8 Threads und unterstützt Intel® Hyper-Threading-Technik.

Habe nun beides probiert und kaum einen Unterschied festellen können (CPU manchmal weniger Auslastung mit der Option an)

vor einer Stunde schrieb AmunSeth:

Was mir öfter mal aufgefallen ist, daß Win gerne mal die Hz-Zahl von monitoren auf 60Hz festlegt, auch wenn diese 75Hz können.
Im Treiber kann man das dann noch festlegen, daß der auf 75 läuft.

Meinst du diese Einstellung: 

41d2b524acc5225eac86c9af54d44412.png.4fdfff22ab03aa3e17fd76e86c4ebfd3.png

Die war vorher schon so eingestellt.

vor einer Stunde schrieb AmunSeth:

Ich habs 15FPS höher eingestellt, als halt im Treiber/etc, um die InputLags zu minimieren, die Donidon schon erwähnt hat.
Dem entsprechend kannst das dannn mal austesten und im Spiel dann mal auf 90 stellen ...

Wie meinst du das mit VSync an aber ingame 90fps einstellen. Soweit ich weiß tut VSync the Fps auf die Hz Zahl des Monitors hartlocken, auch die Fps Einstellung in Tarkov werden "ausgeblendet" so das man sie nicht ändern kann sobald Vsync an ist.

vor einer Stunde schrieb AmunSeth:

VSync sollte dann am besten an sein. (Vsync zieht Leistung, ganz klar, machts aber "flüssiger" ...)

Mit Vsync an habe ich 75fps im Stillstehen aber in Bewegung viele Microruckler und drops unter 75 bis teilweise 51Fps. (GPU/CPU Auslastung 71%/50%)

Ohne Vsync mit einem Cap von 90Fps selten Drops bis 80Fps und kaum Microruckler (GPU/CPU Auslastung 91%/50%)

Das Tearing ist halt ohne Vsync das was mich teilweise verrückt macht und mit Vsync ist mein Spiel sehr instabil.

Gibt es den keine andere Möglichkeit Tearing zu fixen ohne Vsync?

Edited by feduli

Share this post


Link to post
Share on other sites
AmunSeth
Posted (edited)
vor 47 Minuten schrieb feduli:

Meinst du diese Einstellung: 

ja.

vor 47 Minuten schrieb feduli:

Wie meinst du das mit VSync an aber ingame 90fps einstellen. Soweit ich weiß tut VSync the Fps auf die Hz Zahl des Monitors hartlocken, auch die Fps Einstellung in Tarkov werden "ausgeblendet" so das man sie nicht ändern kann sobald Vsync an ist.

ja, vollkommen richtig. aber IG geb ich da einfach noch halt die 15 FPS zu ... Vsync ist bei mir aktiviert. Aber IG nicht geschwärzt, oder ähnliches, wie zu sehen ist.
Daß die FPS dann festgelegt ist, auf den Monitor, ist vollommen richtig und auch Sinn der Sache.
Im "Gaming-Bereich" ist das ja auch prinzipiell eher weniger angewandt und suboptimal.
Aber leider ist das, grad bei älteren Monitoren, notwendig, weil die nicht für's Gaming so sehr geeignet sind.
So ab 75Hz aufwärts fängt's eigentlich an, erträglich zu werden. (EIn Grund, warum halt in absehbarer Zeit auch bei mir ein neuer ran kommen wird, damals war es auch nicht so sehr Priorität)
Das bei Vsync die FPS droppen können, ist normal. Dürfte aber eigentlich gar nicht so ins Gewicht fallen, bei guter Config.
Wenn ich es IG auf 60 FPS stelle, hab ich Mikroruckler.
Deswegen hab ich das (bei mir) so gemacht.

Daran kann es also auch nicht wirklich liegen.
Aber kannst du vll mal versuchen, wenn du halt Hardwaretechnisch alle auf 75Hz festgestellt hast, "Game FPS Limit" halt mal auf 90 statt der 120 zu stellen und schauen, ob sich die Qualität verbessert hat

Nebenher vllt auch noch mal mit ein- / ausgeschaltetem HBAO & SSR statt "medium".

Lieber Gruß

Edited by AmunSeth

Share this post


Link to post
Share on other sites
AmunSeth

ui.
da fällt mir noch was ein ... aber eher nebensächlich gerade, weil ich mich eben erst wieder drüber aufrege :D
Das liegt aber auch nicht zwingend an "EfT" ^.^

Welche Kombination zB bei mir ganz ekelig ist, ist ein laufendes EfT & ein offener Browser
Hier bin ich aber auch recht altmodisch und nutze vorwiegend Firefox ... Kann mich so schlecht an andere gewöhnen.
Da ist das oft ganz schlimm.
Weniger CPU, aber dafür besonders hart, die GPU-Last, wenn Twitch noch offen ist, dann kommts gelegentlich noch zu Rucklern. Aber da nervt eher Twitch, als das Spiel. Oft muss ich den Browser sogar komplett schließen.
Es ist nicht immer, bei jedem der Fall ... das vlltt auch noch ausprobieren, also Browser schließen.

LG

Share this post


Link to post
Share on other sites
feduli

Ich habe es jetzt nochmal versucht wie du es gesagt hast.

Mit Vsync an (75Hz) und ingame 60Fps Einstellung varriert zwischen 45-65Fps.

Mit Vsync an (75Hz) und ingame 120Fps Einstellung varriert zwischen 35-70Fps

Die Microruckler sind halt echt alle 2-5sec was schon sehr nervt. Verstehe halt auch nicht wie das mit Vsync so stark instabil wird, Auslastung war wie gesagt mittelmäßig (CPU 38%/GPU 56%) also warum zieht das Game net mehr Leistung um die 75Fps mit Vsync zuhalten.

Naja schade aber ich denke ich werd mich dann damit abfinden müssen auch wenns sehr stört

Vielen Dank für die Hilfe

Share this post


Link to post
Share on other sites
AmunSeth

Wie ich schon sagte, das Vsync braucht auch Rechenleistung ;)
Das GraKa und Monitor zusammen arbeiten können, muss berechnet werden.
Du hast genaugenommen eine GraKa die für deinen Monitor zu OP ist, was heißt, deine Karte muss das, was sie hochgerechnet hat, anschließend wieder runter rechnen. Das saugt an der Leistung. (So würde ich das nun erklären)

Mit deinem Monitor wirst du immer weiter das Problem haben, daß die Darstellung nicht vernünftig ist, bei so hohen FPS.

120FPS+ funktionieren nicht auf jedem Rechner.
Schon gar nicht, wenn nebenher noch Software offen ist, wie zB Bowser mit X geöffneten Twitch-Tabs, OBS und Co. wenn alles gleichzeitig offen ist...

Frameeinbrüche sind da vollkommen normal.

Das ist der Grund, warum ich die Einstellungen bei mir ja so hab.
"Flüssiger Betrieb", da hab ich meinen Fokus drauf.
Mit hohen FPS brauch ich nicht anfangen, wenn ich zeitgleich auch noch nen Stream anmache.

Ich weiß, was du willst, worauf du hin arbeitest.
Klappt nicht so ganz, wie du dir das vorstellst, leider. :/

bei 75Hz sind 60 zu wenig und 120 zu viel.
Daher das "herantasten".
Direkt immer auf die Extreme zu gehen (ganz hoch, oder ganz niedrig) ist eher suboptimal, wenn es um Fehlersuche geht.
Ein "Mittelweg" ist eher hilfreich.

LG

Share this post


Link to post
Share on other sites
feduli
Posted (edited)

Was meinst du mit sehr hohen Fps? Ich persönlich finde 75 nicht grade viel. 

Ich möchte nur stabile 75Fps haben, ohne Screen Tearing.

vor 58 Minuten schrieb AmunSeth:

Wie ich schon sagte, das Vsync braucht auch Rechenleistung ;)
Das GraKa und Monitor zusammen arbeiten können, muss berechnet werden.
Du hast genaugenommen eine GraKa die für deinen Monitor zu OP ist, was heißt, deine Karte muss das, was sie hochgerechnet hat, anschließend wieder runter rechnen. Das saugt an der Leistung. (So würde ich das nun erklären)

Wenn das stimmt was du sagst müsste aber eine erhöhte Auslastung zu sehen sein wenn Vsync mehr Leistung zieht.

Es ist aber genau das Gegenteil der Fall. (Wie gesagt mit Vsync ist die GPU grad mal auf 50% und nichts anderes ist ansatzweise über 50%, ohne Vsync mit 90Fps Cap GPU 70-90%)

Ich habe alle möglichen Fps Einstellung schon ausprobiert aber es waren nie große Unterschiede (Ausprobiert 60Fps, 75Fps, 90Fps, 100Fps, 120Fps)

Und um nochmal auf Ingame Fps auf höher stellen als meine Hz Zahl zurückzukommen,  macht nur Sinn wenn ich Vsync AUS habe, da es "normalerweise" mit Vsync AN "immer" nur max 75Fps berechnen wird.

Also mein Ziel ist wie gesagt 75Fps stabil zubekommen ohne Screentearing (es muss nicht zwingend mit Vsync sein)

Habe auch öfters gehört das Vsync in Tarkov manchmal eher suboptimal ist

LG

 

Edited by feduli

Share this post


Link to post
Share on other sites
Donidon
vor 17 Stunden schrieb feduli:

Ich möchte nur stabile 75Fps haben, ohne Screen Tearing.

Schafft dein Monitor denn wirklich nur 75Hz? Ich habe einen 60Hz Monitor der über 100Hz schafft.  Ja Monitore kann man auch OC. Dazu muss man nur ein entsprechendes Profil erstellen. Dann ist zumindest das tearing weg, ohne das du vsync benutzen musst.

Vsync nur bei Freesync/Gsync Monitoren, wo diese Funktion im Monitor und der Grafikkarte aktiviert wurde. Bei Monitoren mit fester Frequenz ist vsync zum Spielen in den aller meisten Fällen nicht gut.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...
b38e7c858218a416ef714554dce933a2