Jump to content

I am Encountering an Error: Illegal Characters in Pathway


Miisterio
 Share

Recommended Posts

I have been trying for weeks to fix this issue, It seems that the Game Installer Client doesn't have a Pathway to install the game to. no matter what i do nothing has fixed the issue. I have seem a couple of other people with the same issue, they simply gave up on the game and stopped playing. I have attached screenshots of the error, fingers crossed someone on here knows a fix for this

first.png

fourth.png

second.png

third.png

Link to comment
Share on other sites

Are you trying to install on the root of those drives? meaning are you changing the launcher install path to just for example C:\? or is everything default pathways. The fact that the launcher installed would suggest it had no issue finding the drive and that that drive were correctly named.

There was a major issue with EFT wiping everything on HDDs if it were placed at the root of a drive, meaning if people changed the default pathway from, for example C:\Battlestate games\... to C:\ then trying to install, it would wipe all the data(including OS) off C and make it non functioning. Make sure it is there is always a folder between root and the folder containing the games .EXE.

Try this, completely remove and delete launcher, create a new folder on whatever drive you want the game to install(call it whatever), re download the launcher to that folder, then run and install it from that folder always pointing to that pathway and folder if it doesn't do it by default.

If you are still stuck later I can jump on a discord chat with you and talk you through it. I won't be able to do that though for few hours as I'm off out.

Link to comment
Share on other sites

I just Tried that again. same issue, I'm honestly very confused by this. the only thing I could think is maybe something has happened to my account? like a Ban or something, the only problem with that theory is that I haven't played the game in years

1.png

2.png

3.png

Link to comment
Share on other sites

1 hour ago, Miisterio said:

the only thing I could think is maybe something has happened to my account? like a Ban or something, the only problem with that theory is that I haven't played the game in years

 

 

 

If you were banned, you wouldn't be able to post on here mate.

It's like the launcher is default pointing to a drive that no longer exists. You've not changed hard drives or anything? almost like remnants of an old launcher install are still in the Registry overriding the new install.

Edited by Angrybiker
Link to comment
Share on other sites

11 hours ago, Xarc said:

Have you tried to start the installer as administrator ?

Yes, no change

 

3 hours ago, Angrybiker said:

Are you trying to install to the same drive as the launcher? in your case the D:\ drive? Is there enough space on that drive?

Yeah, i have over 200GB on both drives. I'm not able to actually choose where i want it to install. the installer client won't let me change then path way

Link to comment
Share on other sites

7 hours ago, Angrybiker said:

If you were banned, you wouldn't be able to post on here mate.

It's like the launcher is default pointing to a drive that no longer exists. You've not changed hard drives or anything? almost like remnants of an old launcher install are still in the Registry overriding the new install.

I opened up my Registry Editor and deleted everysingle data point for anything relating to Battlestate games or Escape from tarkov, so that there was no pathway and it had to make its own. I reinstalled the client, got the exact same error

Link to comment
Share on other sites

It's a strange one mate. I've even taken to google to see if I can glean any additional information but as you said, the very small number affected simply gave up and never played the game, which is a shame.

I'm assuming everything is fully updated, Windows, .NetFramework, etc?

Link to comment
Share on other sites

I would say, keep/save important data, wipe/re-partition hard/ssd, reinstall windows (not a single piece of third party (software, drivers (let windows to detect and install), etc.)), update it, install the game then profit.

Link to comment
Share on other sites

10 hours ago, Angrybiker said:

It's a strange one mate. I've even taken to google to see if I can glean any additional information but as you said, the very small number affected simply gave up and never played the game, which is a shame.

I'm assuming everything is fully updated, Windows, .NetFramework, etc?

I just received this message from the support staff. showing their Settings File, which shows the Game Directory code. I followed and opened my file up and Mine doesn't that that line of code anywhere in that file. maybe your file has the code and I might be able to copy into my file? the blacked out bit is just my personal email

 

Sp file.png

Sp.png

My sp File.png

Edited by Miisterio
safety
Link to comment
Share on other sites

Can't help mate, just looked at my settings fine and mine doesn't contain that line either.....

Might be worth trying just backing up the original settings file and then placing that line in there, then running the installer.

Edited by Angrybiker
Link to comment
Share on other sites

Putting this here as the fix. So I found the file that was the issue. you has to edit the folder with the Error. now all I did was delete the invalid character. which were (  *:  ). These were the Error. and since then I have been able to play it now no issues at all

Found the error.png

 

 

Edited by Miisterio
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...