Jump to content
JackGermany

FPS Probleme

Recommended Posts

JackGermany

Hallo zusammen,

ich habe da ein Problem.
Ich habe extreme FPS Schwankungen unter Customs und allgemein eine rate von 10-15 FPS.
Habe vor kurzer Zeit meinen PC neu aufgesetzt und escape über eine SSD Laufen. Davor lief es über die HDD genau so besch...
Habe es heute mit einer neuen Graka ausprobiert aber es hilft dennoch nichts.

Vielleicht hat ja wer von euch eine Idee woran das liegen kann.

Mein PC:

CPU: AMD Phenom II x6 1090T
Mainboard: M4A88T-V EVO/USB3
Graka: Gigabyte GTX 1070 8gb
SSD:  500GB
150 MB Leitung

 

Beste Grüße

r1oT

Share this post


Link to post
Share on other sites
ningamertendo

Schon einmal deine CPU Auslastung angesehen? Gerade deine CPU scheint mir hier ein Problem darzustellen, da diese bereits 7 Jahre auf dem Buckel hat. Ebenso sollte man wissen wieviel RAM du zur Verfügung hast, denn das ist eine der aktuell kritischen Punkte des Spiels:

Die SSD ist ein gutes Plus jedoch kein muss für ein flüssiges Spiel, da es im 64 Bit Modus läuft. Lediglich die Ladezeiten machen sich daraufhin bemerkbar.

Share this post


Link to post
Share on other sites
JackGermany
vor einer Stunde schrieb ningamertendo:

Schon einmal deine CPU Auslastung angesehen? Gerade deine CPU scheint mir hier ein Problem darzustellen, da diese bereits 7 Jahre auf dem Buckel hat. Ebenso sollte man wissen wieviel RAM du zur Verfügung hast, denn das ist eine der aktuell kritischen Punkte des Spiels:

Die SSD ist ein gutes Plus jedoch kein muss für ein flüssiges Spiel, da es im 64 Bit Modus läuft. Lediglich die Ladezeiten machen sich daraufhin bemerkbar.

Also ich habe 20gb ram und die CPU ist bei 50 bis 60 Prozent. Auslastung. Also von der Leistung her läuft er super entspannt :/

Edited by JackGermany

Share this post


Link to post
Share on other sites
ningamertendo
vor 20 Minuten schrieb JackGermany:

Also ich habe 20gb ram und die CPU ist bei 50 bis 60 Prozent. Auslastung. Also von der Leistung her läuft er super entspannt :/

Das kann tatsächlich schon an der Grenze liegen, da ich mit meinem i7 4790k etwa 35% Auslastung bekomme. So wie ich das eben einschätze, ist das Spiel noch nicht auf viele Kerne ausgelegt.

Bist du denn selbst bei low Einstellungen bei diesen wenigen FPS?

  • Sad 1

Share this post


Link to post
Share on other sites
JackGermany

Leider ja... In anderen games habe ich sehr gute fps raten aber nicht bei eft... 

Share this post


Link to post
Share on other sites
FSN_RolexXx

Hallo euch Allen, ich hab die Probleme auch aber nicht nur in Custom. Mir friert das Spiel ein für ne gute Sekunde sobald ein Spieler oder KI in der nähe ist. Ich Denk mal das es am Netcode liegt. 

 

Share this post


Link to post
Share on other sites
ningamertendo
vor 26 Minuten schrieb FSN_RolexXx:

Hallo euch Allen, ich hab die Probleme auch aber nicht nur in Custom. Mir friert das Spiel ein für ne gute Sekunde sobald ein Spieler oder KI in der nähe ist. Ich Denk mal das es am Netcode liegt. 

 

Die Freezes sind eher ein Zeichen für einen Memory Leak

Share this post


Link to post
Share on other sites
OsmartiehE

Hallo JackGerman,

 

also bei mir läuft es alles einwandfrei mit:

 

Prozessor: Intel Core i3 4130

CPU: Intel Quad-Core 3,4GHz

Mainboard: Gigabyte Z97P-D3

RAM: 16GB DDR3 (nicht das aktuellste)

Graka: NVIDIA Geforce GTX 970

Grafikeinstellungen-INGAME: Alles auf High (FPS 65-90 durchgängig egal ob es regnet oder aus allen ecken geballert wird)

Wie du siehst, nicht gerade besser als deine Daten,

ABER ich habe gehört das INTEL einfach Leistungsfähiger und schneller ist, wie aus den Kommentaren über mir, würde ich auch stark behaupten - trotz deiner SSD das dein "toller" AMD-Prozessor der Bösewicht ist. :P

Edited by OsmartiehE

Share this post


Link to post
Share on other sites
Balu0408

Ich habe auch starke FPS-Probleme, kurzzeitig schaffe ich es mal auf 60-70 überwiegend bewege ich mich aber um die 30 und bekomme auch dropps unter 10. Die schlechten FPS gehen immer mit schlechten Render-ms Werten einher. Selbst Factory ist nach einer Weile nicht mehr spielbar. Ob ich die Grafikeinstellungen im Spiel auf low oder medium habe ändert nicht wirklich was an den FPS.

Ich spiele auf einem Laptop mit folgenden Werten:

Prozessor: Intel Core i5 7300 HQ

CPU: Intel Quad-Core 2,5GHz mit Boost auf 3,5Ghz

RAM: 8GB DDR4

Graka: NVIDIA Geforce GTX 1050 2GB

Die RAM-Auslastung ist während dem Spiel um die 85-95%, CPU um die 60%+.

Im Vergleich laufen Spiele wie Pubg(Grafik komplett auf sehr low) etwas besser aber auch da bekomme ich oft Drops, obwohl die RAM-Auslastung deutlich geringer ist, was mich dahingehend verunsichert ob eine RAM-Aufrüstung auf 16GB+ überhaupt was nutzen würde. Auch wenn jeder meint es würde an den RAM liegen könnte es auch dran liegen, dass meine Graka nur 2GB RAM hat oder der Laptop einfach überhitzt?

 

Share this post


Link to post
Share on other sites
PIK

naja, auf einem notebook spielen ist immer so eine sache, aber eigentlich wenn sonst drum rum (internetverbindung, leistungseinstellung von windows und nvidia) alles stimmt, solltest du das game schon annehmbar spielen können, sicher nicht wie auf einem 1000€ desktop pc, aber schon spielbar

der hinweis dass dein game eigentlich ganz gut läuft und dann runter auf 10fps stürzt klingt für mich stark nach daten vom swapfile in den ram laden, auf factory solltest du das zum beispiel nicht haben, weil die map wesentlich kleiner ist als die anderen

das factory nach einer weile nicht mehr spielbar ist kann ein auftretendes ramleak sein, kommt auch drauf an, was du mit einer weile meinst, so 2 bis 3 runden factory sollten schon annehmbar laufen (abgesehen von den ganz normalen d-syncs) bevor es anfängt zu laggen

 

du kannst den nächsten patch abwarten (paar tage, nichts genaues weiß man nicht), wenn du die geduld hast und warten ob sich mit dem ramhunger von eft was verbessert, die devs meinten sie würden fleißig optimieren in der richtung

naja und wenn das alles nichts hilft würde ich dir auf jeden fall dazu raten mal testweise auf 16gb aufzurüsten, vorher abklären ob das mit der rückgabe klar geht

weil bei vielen leuten hier im forum haben sich diese starken fps drops nach dem aufrüsten in luft aufgelöst

  • Thanks 1

Share this post


Link to post
Share on other sites
Balu0408

Erstmal vielen Dank für deine schnelle Antwort, du scheinst dich gut auszukennen!

Die Leistungseinstellungen von Windows als auch die von NVIDIA sind alle auf max. eingestellt.

Ich habe Factory gerade nochmal getestet. Laptop Neugestartet und Eft über Razor Cortex gestartet. Hatte 3 Games in Folge durchgehend 60 FPS+, sogar mit Texturen auf Medium und Sichtbarkeit auf 3k. Wenn Factory für mich unspielbar war, habe ich vorher warscheinlich noch andere Maps gespielt. Kann ich damit sicher sagen, dass bis auf mein RAM die anderen Komponenten "Ok" sind und die Aufrüstung mit guter Wahrscheinlichkeit das von dir beschriebene Problem mit dem Swapfile behebt?

Ich frage mich dann dennoch warum ich bei Pubg FPS drops bekomme obwohl es viel weniger RAM benutzt.

Edited by Balu0408

Share this post


Link to post
Share on other sites
PIK
vor 8 Stunden schrieb Balu0408:

Kann ich damit sicher sagen, dass bis auf mein RAM die anderen Komponenten "Ok" sind und die Aufrüstung mit guter Wahrscheinlichkeit das von dir beschriebene Problem mit dem Swapfile behebt?

mit großer wahrscheinlichkeit =)

eft hat zur zeit mehrere baustellen wo es knarrt und kracht, aber 16gig arbeitsspeicher wären für diesen speziellen bug schon sehr hilfreich, wenn du dann mehrere runden shoreline spielst, dann kann das game mit auftretenden ramleak auch auf 14-15gb hochschießen (bei dir dann natürlich nicht, weil der rest im swapfile landet), aber selbiges wie bei factory, 2-3 runden shoreline sollten mit 16 ohne probleme machbar sein

ja pubg ist nochmal ne andere sache, hab mich zwar mal 200h mit dem game befasst, aber nie im foren etc. wissen dazu angeeignet, da müsstest du dich dann in einem pupg forum beraten lassen :D

aber wenns so wie bei h1 ist, sind battleroyale shooter aufgrund der vielen leute, die auf den maps rumwusseln, einfach cpu lastiger

 

  • Upvote 1

Share this post


Link to post
Share on other sites
PIK

japp das game ist in der hinsicht wirklich merkwürdig, das multithreading funktioniert noch nicht mit allen cpu besonders gut,

mein alter 9370 wollte ums verrecken nicht mehr als die ersten 4 threads benutzen (2 kerne), dass musste ich dann alles per hand einstellen und dann gings....

Share this post


Link to post
Share on other sites
ningamertendo
vor 5 Stunden schrieb PIK:

japp das game ist in der hinsicht wirklich merkwürdig, das multithreading funktioniert noch nicht mit allen cpu besonders gut,

mein alter 9370 wollte ums verrecken nicht mehr als die ersten 4 threads benutzen (2 kerne), dass musste ich dann alles per hand einstellen und dann gings....

Bei mir mit meinem i7 4790k komme ich auf 4 logische Prozessoren, welche fast 100% ausgelastet sind. Meine anderen bleiben dabei nur leicht angetastet und das wegen allen anderen Programmen. Ich komme daher auch eher auf weniger FPS als andere mit der gleichen GPU, wobei meine manuell auf maximale crashfreie Werte übertaktet ist.

Share this post


Link to post
Share on other sites
PIK

naja, mal sehen, in den patchnotes stehen ja schon ein paar sachen in richtung optimierung

Edited by PIK

Share this post


Link to post
Share on other sites
JackGermany

So Update habe für mein System mehr als 1K ausgegeben.

Daten:

CPU: AMD Ryzen x1700 8 core
Graka: Gigabyite 1070, 8 GB
Mainboard: MSI Tamahawk 350B
16 GB DDR4 2300mhz
Windows 10
SSD  etc

 

Also wie siehst nun aus wieso habe ich immer noch die gleichen FPS Werte wie davor.... Ich verstehe die Welt nimmer....

Share this post


Link to post
Share on other sites
PIK

wie vorher = 15fps?

Share this post


Link to post
Share on other sites
JackGermany

Jap hat sich kaum was geändert .... 

Share this post


Link to post
Share on other sites
ningamertendo
vor 6 Stunden schrieb JackGermany:

Jap hat sich kaum was geändert .... 

In wiefern ist dein Ryzen ausgelastet? Es kann sein, dass noch nicht die Optimierung für AMD Prozessoren getätigt wurde. Ansonsten bei jedem aufrüsten:

1. Alle Treiber aktualisieren.

2. Bios auf den neuesten Stand setzen.

Ist vllt auch wieder ein Memoryleak vorhanden? Kann ebenfalls an der AMD Reihe liegen.

  • Sad 1

Share this post


Link to post
Share on other sites
Balu0408

Kleines Update, ich komme mittlerweile auf Factory auf 80-100 Fps, auf Woods auf 50-70 jedoch auf Shoreline irgendwie nur auf 40. Customs wahrscheinlich noch weniger, habe ich aber nicht ausprobiert.

Das habe ich hinbekommen, indem ich das Spiel deinstalliert und diesesmal auf der SSD installiert habe. Dann habe ich noch die Energieoptionen von "Höchstleistung" auf "Empfehlung" umgestellt, dort aber die max. Prozessorleistung auf 85% hoch gestellt dadurch bleibt die CPU unter 90 °C und GPU unter 80 °C womit Thermal Throttling aus bleibt.

Mein RAM-Problem bekommt "Wize Memory Optimizer" halbwegs in den Griff, allerdrings optimiert er trotz entsprechender Einstellungen nicht automatisch während ich im Spiel bin. Kennt jemand evtl. ein Programmm, welches wirklich durchgehend selbstständig optimiert?

Aktuell bekomme ich eigentlich nur noch Dropps, wenn Wize den RAM nicht optimiert(sobald ich es selber manuell mache, kommen die FPS auch wieder hoch), durch steigen der Fupd-, Uupd- und Gameupd-Werte. Liegt das eher an meiner Verbindung oder habt ihr das evtl. auch, und es liegt an den Servern?

 

Edited by Balu0408

Share this post


Link to post
Share on other sites
PIK
vor 5 Stunden schrieb ningamertendo:

2. Bios auf den neuesten Stand setzen.

finger weg vom bios ;) das bios vom mainboard updatet man nur, wenn man eines der feature benötigt, dass in einer neuen version enthalten ist

 

zurück zu den fps problemen, ja kann sein @JackGermany dass dein ryzen nur auf 2 kernen (4threads) läuft, wie weiter oben erwähnt gibt es da einige probleme mit AMD CPUs und EFT. Habs bei mir über ProcessLasso gelöst und die verwendeten cores per hand eingestellt und die windows standardeinstellung überschrieben

im englischen forum waren auch ein paar leute mit 1700er und 1500er ryzen, denen habe ich das selbe empfohlen, da ich keinen mehr von denen hab meckern sehen, gehe ich mal davon aus dass es geklappt hat (oder sie sind explodiert oder so :ph34r:)

 

Share this post


Link to post
Share on other sites
ningamertendo
vor 1 Minute schrieb PIK:

finger weg vom bios ;) das bios vom mainboard updatet man nur, wenn man eines der feature benötigt, dass in einer neuen version enthalten ist

Wenn du ein einigermaßen aktuelles hast kann das jeder Leihe machen, jedoch ist das nicht das einzige schließlich ist das Bios nicht lediglich für die Initialisierung der Komponenten zuständig, sondern beinhaltet auch den CPU Treiber. Gab bei Intel mal einen Bug, welcher nur durch das Bios gelöst werden konnte.

Share this post


Link to post
Share on other sites
PIK
vor 1 Minute schrieb ningamertendo:

Gab bei Intel mal einen Bug, welcher nur durch das Bios gelöst werden konnte.

ich bin nicht gegen Bios updates an sich, hab mir nur abgewöhnt leuten in foren dazu zu raten xD

manche leute updaten ihr bios auf jede neue version (obwohl sie die garnicht brauchen) und irgendwann ist ihr eprom hinüber und sie fahren notprogramm bei erloschener garantie.... die mainboardhersteller schreiben genau daneben, in den patchnotes, was geändert wurde (also die hersteller die ich so kenne) und wenn da nichts dabei ist was man benötigt, dann sollte man das bios auch nicht updaten, das risiko was kaputt zu machen ist höher als ein eventueller nutzen, wie gesagt einzelfall abhängig

Share this post


Link to post
Share on other sites
ningamertendo
vor 1 Minute schrieb PIK:

manche leute updaten ihr bios auf jede neue version (obwohl sie die garnicht brauchen) und irgendwann ist ihr eprom hinüber und sie fahren notprogramm bei erloschener garantie.... die mainboardhersteller schreiben genau daneben, in den patchnotes, was geändert wurde (also die hersteller die ich so kenne) und wenn da nichts dabei ist was man benötigt, dann sollte man das bios auch nicht updaten, das risiko was kaputt zu machen ist höher als ein eventueller nutzen, wie gesagt einzelfall abhängig

Gut das würde ich auch nicht machen, jedoch sind die Mainboards ab Auslieferung meistens auf der ersten Version. Daher der Punkt ;)  

Share this post


Link to post
Share on other sites
PIK

ja das stimmt meißt ist noch die 1.00 drauf wenn man nen rev.A gekauft hat, da muss man sich alles mal genau durchlesen, manchmal werden auf nur neue ramtypen oder andere prozessoren unterstützt und wie gesagt wenn man die nicht braucht, dann kann man sich das risiko sparen und diese updates auslassen

hab mich damals mal angeschissen mit nem board, schon ein paar jahre her, hab auf ein bestehendes board nur ne neue cpu und neuen ram draufgepackt und hatte probleme den ram auf die gewünschte frequenz zu bekommen, ich mach also nen biosupdate weil drinnen stand das es da verbesserungen gab, leider habe ich übersehen, dass mit der biosversion einige cpus nicht mehr unterstützt wurden.... natürlich genau der den ich eingebaut hatte.... das war ne heiden arbeit das bios update programm zu zwingen die alte version wieder drauf zu laden O.o den ram dann mit etwas weniger mhz laufen lassen, war dann das kleinere übel

und ich bin gelernter systemelektroniker, da möchte ich nicht wissen was da leute machen, die dann keinen plan haben :D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...
b38e7c858218a416ef714554dce933a2