Jump to content
Jushi85

Windows 10 Fall Creators Update ~30fps low fps fix

Recommended Posts

Hi guys,

i'm not sure if this is posted already...but here it goes!

i had this problem of game being about 20-30 fps regardless of graphics settings. i first thought that my very old xeon cpu is the reason for the low fps, but then i found a fix via another OP's thoughts on Guru3D.com forum.

He had the same problem with some other Unity based games, and he said that if you use Windows 10's new Fall Creators Update, the bug might be present in many unity based games he thought.

-----------------------------

the fix is simple: 

go to X:\Escape from Tarkov game folder, right-click the EscapeFromTarkov.exe and choose properties, go to compatibility tab.

Then change the "Scaling is done by:" option to "Application"--->then tick the "disable fullscreen optimizations".

-----------------------------

 

That should be it. the game should be alot smoother overall and fps much better, atleast on my pc it did the trick.

 

the_fix.png

  • Like 1
  • Thanks 4
  • Upvote 4

Share this post


Link to post
Share on other sites

Dude, thank you so much for this solution! I don't play this game but it helped me with cs:go and other games after upgrade to win10 from win7! I tried everything but nothig worked except this one.

Greeting from Poland!

Share this post


Link to post
Share on other sites

 

On 13/11/2017 at 8:01 PM, Jushi85 said:

Hi guys,

i'm not sure if this is posted already...but here it goes!

i had this problem of game being about 20-30 fps regardless of graphics settings. i first thought that my very old xeon cpu is the reason for the low fps, but then i found a fix via another OP's thoughts on Guru3D.com forum.

He had the same problem with some other Unity based games, and he said that if you use Windows 10's new Fall Creators Update, the bug might be present in many unity based games he thought.

-----------------------------

the fix is simple: 

go to X:\Escape from Tarkov game folder, right-click the EscapeFromTarkov.exe and choose properties, go to compatibility tab.

Then change the "Scaling is done by:" option to "Application"--->then tick the "disable fullscreen optimizations".

-----------------------------

 

That should be it. the game should be alot smoother overall and fps much better, atleast on my pc it did the trick.

 

the_fix.png

damn, that options is only on win10 :(

Share this post


Link to post
Share on other sites

didn't seem to work for me. i don't get any more frames. i have windows 10 and did what was required. no change for me, unfortunately

didn't work for my buddy either.

Edited by JJamie

Share this post


Link to post
Share on other sites
23 hours ago, JJamie said:

didn't seem to work for me. i don't get any more frames. i have windows 10 and did what was required. no change for me, unfortunately

didn't work for my buddy either.

Same here, seems like a placebo fps fix. 

Share this post


Link to post
Share on other sites
6 minutes ago, Sn0wleopardd said:

Same here, seems like a placebo fps fix. 

before i did it i had 30+ fps on shirline after that i had 70+. definitely not placebo.

Share this post


Link to post
Share on other sites
3 minutes ago, lizakk said:

before i did it i had 30+ fps on shirline after that i had 70+. definitely not placebo.

i7-4790k @4.4Ghz

970 FTW 1496Mhz Core / 4005Mhz Mem

32GB RAM @2133Mhz

 

Made zero improvement to my FPS. If it did improve my FPS, it was +/- 5 so barely any difference. 

Edited by Sn0wleopardd

Share this post


Link to post
Share on other sites
Just now, Sn0wleopardd said:

i7-4790k @4.4Ghz

970 FTW 1496Mhz Core / 4005Mhz Mem

32GB RAM @2133Mhz

 

Made zero improvement to my FPS. 

sorry to hear that bro. i really dont know how or why it works at all. im jsut syaing it helped me and if it did i gess there are some pepole that this might help also. sorry to hear youre not one of them.

  • Like 1

Share this post


Link to post
Share on other sites

it does seem odd that it would work for some and not others. clearly there is something else that is in play.

Share this post


Link to post
Share on other sites

I think this fix only works for people who are using windowed mode. After the update, I was getting noticeably worse frames in a different game until I set it to fullscreen. I could be wrong though, I haven't done any sort of extensive testing.

Share this post


Link to post
Share on other sites

This worked for me. I just got the fall creators update installed yesterday. Before the update my gameplay on shoreline was smooth as it can be under the circumstances... but after the update I got huge FPS dips and micro stutters while runing around on the map even in PVE mode. 

So this fix made it just like it was before the windows update.

 

PS: I'm playing on a MSI GE70 apache pro laptop.

Share this post


Link to post
Share on other sites

Well, that great if this simple trick helps you to fix the issue but if you want to fix it permanently then try some other tips to permanently solve the issue.

Turn off the unwanted programs, the programs that come with the default setting to start on computer startup. So, the reason it will start running in the background as the users log on the computer. Apart from that check for drivers and even scan for virus or malware to fix the Windows 10 lag issue.

fixwindowserrors.biz

Edited by lorein0688

Share this post


Link to post
Share on other sites

Just stumbled upon this post, can't wait to give it a try when I get home later today. I have a GTX 1080Ti and even I don't get the best frames on ultra, and when I switch to med/low the frames are only maybe 5-10 fps better, which is absurd. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×