Jump to content

Analog Controller Device Issues


Orkan

Recommended Posts

Greetings,

As the  game is now closed beta certain issues caused by controllers such as joysticks, throttles and pedals need to be addressed. Some players wish to bind an analogue controller for character movement and leaning and being able to do so is a great move by the game. However a problem exists and that is that the game DOES NOT detect individual devices and instead adds all axes from all connected controllers.

In order to bind a joystick correctly the game should differentiate between multiple devices so the player can bind the appropriate one. Other devices should not be autodetected and stacked to create an overload of inputs feeding the game.

I for example have a flight sim setup with, 2 joysticks, Hotas and flight pedals and all of those axes were conflicting to result in my character spinning uncontrollably on the spot. The only solution is to disable in windows (too lengthy to be practical) or unplug the devices I am not using. However this is not a solution.

Look to how Arma 3 handles joysticks and controllers. Present in keybindings is a way to enable or disable each USB device connected to the computer and to bind them all individually. This will lead to an immense quality of life improvement to this already good game. I like to move my character with a joystick in all the games I play and aim with a mouse. All good games enable a way to achieve this. Many bad games don't even consider the possibility that there could be extra USB device controllers plugged in and release forcing players with complicated setups to manually unplug. Please do the right thing and be like the good games and enable solid and complete analog controller device options.

  • Upvote 1
Link to post
Share on other sites
  • 3 weeks later...

Same issue for me, lame that this post is getting ignored, I also have a flight sim setup and I'm not gonna unplug it every time I want to play escape from tarkov, there should be an option to disable the joystick, so until we have a fix I'm not playing the game

Link to post
Share on other sites
PotatoWarriah

This is known issue, and known workaround is to plug joysticks/controllers out before starting the game. You could also edit shared.ini file in Documents/Escape From Tarkov and remove all bindings for controllers if you want to permanently solve it without unplugging.

  • Thanks 2
Link to post
Share on other sites
  • 1 month later...

trying to I know that if you go to settings the press the ` or ~ button and it brings up the command line then I can type a command. I am looking for the command to zero out my joystick I thought it was "joystick 0" but it says "not a command". Does anyone know what the command is for joystick zero and the command to display frames per second. Thanks

Link to post
Share on other sites
On 11/12/2017 at 10:35 AM, PotatoWarriah said:

You could also edit shared.ini file in Documents/Escape From Tarkov and remove all bindings for controllers if you want to permanently solve it without unplugging.

Great solution, worked like a charm!
Thank you, that controller issue was really disappointing!!

Link to post
Share on other sites
  • 3 months later...
Game_Overture

Necroing this thread because I have the same issues as OP. I also can't even bind keys the options because it detects some joystick is always deflected in some axis at all times.

The game is unplayable in this state for me.

Link to post
Share on other sites
strikeeagle345
On 1/15/2018 at 2:16 PM, Deute said:

Great solution, worked like a charm!
Thank you, that controller issue was really disappointing!!

How do you do this?

Link to post
Share on other sites
OneEyed_Cat
8 minutes ago, strikeeagle345 said:

How do you do this?

 

10 hours ago, jknobler said:

Necroing this thread because I have the same issues as OP. I also can't even bind keys the options because it detects some joystick is always deflected in some axis at all times.

The game is unplayable in this state for me.

 

Find the shared.ini file in the folder Escape from Tarkov. Then you look for all entries named "joystick" and delete them if you want. But make a copy before just to be sure.

EG you delete what's underlined (if you have binded other controls for the same command).

 "axisBindings": [
    {
      "axisName": "LeanX",
      "pairs": [
        {
          "positive": {
            "isAxis": false,
            "keyCode": "E",
            "axisName": "",
            "positiveAxis": false,
            "deadZone": 0.0,
            "sensitivity": 100.0
          },
          "negative": {
            "isAxis": false,
            "keyCode": "Q",
            "axisName": "",
            "positiveAxis": false,
            "deadZone": 0.0,
            "sensitivity": 20.0
          }
        }
      ],
      "isInverted": false,
      "gravity": 0.0,
      "snapToZero": false
    },
    {
      "axisName": "MoveX",
      "pairs": [
        {
          "positive": {
            "isAxis": true,
            "keyCode": "None",
            "axisName": "Joystick Axis 1",
            "positiveAxis": true,
            "deadZone": 0.2,
            "sensitivity": 1.0
          },
          "negative": {
            "isAxis": true,
            "keyCode": "None",
            "axisName": "Joystick Axis 1",
            "positiveAxis": false,
            "deadZone": 0.2,
            "sensitivity": 1.0
          }

        }
      ],
      "isInverted": false,
      "gravity": 0.0,
      "snapToZero": false
    },
    {
      "axisName": "MoveY",
      "pairs": [
        {
          "positive": {
            "isAxis": true,
            "keyCode": "None",
            "axisName": "Joystick Axis 2",
            "positiveAxis": false,
            "deadZone": 0.2,
            "sensitivity": 1.0
          },
          "negative": {
            "isAxis": true,
            "keyCode": "None",
            "axisName": "Joystick Axis 2",
            "positiveAxis": true,
            "deadZone": 0.2,
            "sensitivity": 1.0
          }

        }
      ],
      "isInverted": false,
      "gravity": 0.0,
      "snapToZero": false
    },

 

Link to post
Share on other sites
  • 2 weeks later...
wardinson
Quote

EG you delete what's underlined (if you have binded other controls for the same command).

that does nothing. necroing this thread there is still no response and the issue is still very prevalent. 

Link to post
Share on other sites
  • 4 months later...

The problem is that as long as a controller is plugged in that emits a signal, keys for instance cannot be rebound without EFT picking the axis signal instead of the keyboard button that was pressed. This is sadly in part due to laziness of a programmer that does not want to implement the controllers correctly as they should in Unity. I play EFT a few times a day, as well as DCS World and other flight sims. I bought a powered USB Hub years ago to overcome the laziness of devs so I can turn off the USB devices before entering the shooter, and then fire them all up when I want to fly.

This laziness do not reflect well on a programmer's CV; Ubisoft was notorious for this, especially when doing ports to the PC from console. In a modern shooter, this should not be an issue. Each controller device should be detected, and distinguishable from the mouse and keyboard. 

So please guys, do the right thing and fix this.

Link to post
Share on other sites
10 minutes ago, Warmoer said:

The problem is that as long as a controller is plugged in that emits a signal, keys for instance cannot be rebound without EFT picking the axis signal instead of the keyboard button that was pressed. This is sadly in part due to laziness of a programmer that does not want to implement the controllers correctly as they should in Unity. I play EFT a few times a day, as well as DCS World and other flight sims. I bought a powered USB Hub years ago to overcome the laziness of devs so I can turn off the USB devices before entering the shooter, and then fire them all up when I want to fly.

This laziness do not reflect well on a programmer's CV; Ubisoft was notorious for this, especially when doing ports to the PC from console. In a modern shooter, this should not be an issue. Each controller device should be detected, and distinguishable from the mouse and keyboard. 

So please guys, do the right thing and fix this.

why would you wanna use a controller anyway for this game lol

Link to post
Share on other sites
5 hours ago, saibot0 said:

why would you wanna use a controller anyway for this game lol

Using, e.g., rudder pedals for smooth leaning is something that has been used in many games including Arma 3, so there are plenty of uses.

Also, it's not always about using it, but that the game is thinking you are using it when trying to bind controls.

Edited by BlueDevil
Link to post
Share on other sites
21 hours ago, saibot0 said:

why would you wanna use a controller anyway for this game lol

As BlueDevil said, I don't want to use a controller; my flight controls are plugged into my PC all the time and I don't plan to use them in EFT. There should however be an option for users that do have a controller plugged in and do not want to use that controller in game to be able to disable that controller input.

Many players of EFT do also play flight sims and do not like to have to manually enable/disable controllers to make it compatible with their shooters when the easy thing to do is for the dev just to add an option to enable/disable controllers. 

Link to post
Share on other sites
  • 8 months later...
ShiroTenshi

Sadly there is no ETA on when the DEVs will address this issue. But please make sure to submit bug reports through the launcher explaining it so that at the very least they are aware of it.

Link to post
Share on other sites
  • 5 months later...

I just bought the game today and upon trying to customize my keybindings this is the very first thing I run into. Not a great start. I understand the game is still in development, but for how long it has been playable, I would think this would have been addressed sooner, or at least have a dev response. Not impressive. I have a flight control setup for other games I play and unplugging them every time I want to play this game would be an inconvenience, to say the least. 

Link to post
Share on other sites
  • 11 months later...

Raising this muthaflipping thread from the dead because I still have this issue. I have a sim racing rig plugged in and I'm not unplugging all that.

If I try to rebind a key, or even change volume, things go nuts. I do not have "joystick" in my share.ini so there is nothing to unbind. Not sure how the devs made it so a game reacts to every input. Never had this issue in any other game in my life.

Link to post
Share on other sites
  • 1 month later...
  • 3 weeks later...
On 12/25/2020 at 4:27 PM, fritzykoala said:

I need some help with configuring the controller .. i tried doing it through steam and it doesn't connect.

You need to load up steam and enter full screen mode. Have the controller turned on. Then load Tarkov and it'll work.

Link to post
Share on other sites
  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...