Jump to content

Access Denied


Recommended Posts

I played the game last night and everything went fine and smooth. I'm trying to start the launcher tonight and a pop up saying "Access Denied" has popped up. Anyone else experiencing this? Servers down?

Link to post
Share on other sites
6 minutes ago, Azwei35 said:

thats what im trying to figure out.  i downloaded the game today and havent been able to get into a server for about 4 hours.  stuffs all messed up


Read above? O.o

Link to post
Share on other sites

I just tried to start game and the launcher would not initialise; after several attempts I restarted my PC and again tried to open the launcher. This time it opened, performed an initialisation check and all is right and proper in the universe :) (hope this helps).

Good hunting/

Link to post
Share on other sites
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...