Jump to content
GibsonRSA

Anticheat Connection Lost - Is there a solution?

Recommended Posts

GibsonRSA

I keep getting "Anticheat Connection Lost" error in the game.

I've tried a few things which is listed below.

 

Things I don't do:

  1. I don't run cheat software.
  2. I don't run Reshade or any other graphics manipulating apps

Things I've tried:

  1. Disabling Firewalls
  2. Disabling Anti-Virus
  3. Changing my ingame name
  4. Closing all non-essential apps and services
  5. Running the Launcher as an administrator
  6. Checking DirectX version is up to date
  7. Checking Graphics Card drivers are up to date
  8. Logged a bug report through the game Launcher

Things I haven't tried:

  1. Reinstalling the game
  2. Reinstalling Windows
  3. Selecting another server - I'm unable to do this, checking the box for another server does not seem to work, not sure why.
  4. The logs don't seem to say much about the problem that I can use the troubleshoot myself.

 

Some of the log strings are below.

 

This is the error log for the first try

2018-11-13 05:13:11.155 +02:00|0.10.6.2131|Error|Default|Cannot set searched in grid 1 in item bearRig (id: 5bea2ea7f0dd3539964305af) for item mag_ak_custom_sawed_off_762x39_10 (id: 5bea2ea7f0dd3539964304d6) for profile 5a9d583088a45006016ef7fc

Unknown items: 0

|

2018-11-13 05:13:13.079 +02:00|0.10.6.2131|Error|Default|Cannot set searched in grid 1 in item bearRig (id: 5bea2ea7f0dd3539964305af) for item mag_ak_custom_sawed_off_762x39_10 (id: 5bea2ea7f0dd3539964304eb) for profile 5a9d583088a45006016ef7fc

Unknown items: 0

|

2018-11-13 05:13:14.056 +02:00|0.10.6.2131|Error|Default|Cannot set searched in grid 4 in item bearRig (id: 5bea2ea7f0dd3539964305af) for item mag_ak_custom_sawed_off_762x39_10 (id: 5bea2ea7f0dd3539964304e9) for profile 5a9d583088a45006016ef7fc

Unknown items: 0

|

2018-11-13 05:14:00.287 +02:00|0.10.6.2131|Error|Default|NetworkGame.StopCoroutine error:Anticheat connection lost|

2018-11-13 05:14:01.418 +02:00|0.10.6.2131|Error|Default|Game stopped error:Anticheat connection lost|

 

Error Log when reconnecting to the game

2018-11-13 05:24:39.831 +02:00|0.10.6.2131|Error|Default||

EXCEPTION: System.NullReferenceException:

at (wrapper managed-to-native) UnityEngine.Component:get_gameObject ()

at EFT.Player+.MoveNext () [0x00000] in <filename unknown>:0

at Diz.Jobs.JobScheduler.LateUpdate () [0x00000] in <filename unknown>:0

2018-11-13 05:24:39.831 +02:00|0.10.6.2131|Error|Default|NullReferenceException

EFT.Player+.MoveNext ()

Diz.Jobs.JobScheduler.LateUpdate ()

UnityEngine.DebugLogHandler:LogException(Exception, Object)

:UnityEngine.ILogHandler.LogException(Exception, Object)

UnityEngine.Debug:LogException(Exception)

EFT.:(Exception)

Diz.Jobs.JobScheduler:()

Diz.Jobs.JobScheduler:LateUpdate()

|

2018-11-13 05:24:39.858 +02:00|0.10.6.2131|Error|Default|Can't enabled ArmsAnimatorCommon. ArmsUpdateMode:Manual exception:System.NullReferenceException: Object reference not set to an instance of an object

at EFT.ObservedPlayer. () [0x00000] in <filename unknown>:0 |

2018-11-13 05:24:39.858 +02:00|0.10.6.2131|Error|Default|System.NullReferenceException: Object reference not set to an instance of an object

at EFT.ObservedPlayer+.EFT.ObservedPlayer.. ( , . ) [0x00000] in <filename unknown>:0

at EFT.ObservedPlayer. ( ) [0x00000] in <filename unknown>:0

at . (. ) [0x00000] in <filename unknown>:0

at EFT.ObservedPlayer+.MoveNext () [0x00000] in <filename unknown>:0 |

2018-11-13 05:26:27.423 +02:00|0.10.6.2131|Error|Default|NetworkGame.StopCoroutine error:Anticheat connection lost|

2018-11-13 05:26:28.523 +02:00|0.10.6.2131|Error|Default|Game stopped error:Anticheat connection lost|

Share this post


Link to post
Share on other sites
Forien
On 11/13/2018 at 7:36 AM, GibsonRSA said:

Things I haven't tried:

  1. Reinstalling the game
  2. Reinstalling Windows
  3. Selecting another server - I'm unable to do this, checking the box for another server does not seem to work, not sure why.
  1. Probably should have try that (and to be 100% sure, disable all antivirus software during installation, as some low-end AV software can mess things up)
  2. no idea
  3. try setting it to auto?

Also, try posting bug report, because no idea how much help you will get from us here on forums. 

Edited by Forien

Share this post


Link to post
Share on other sites
RayStark

Having the same problem. On some days its worse than others.

Share this post


Link to post
Share on other sites
Iguana81

I have the same problem.  Reinstal game dont help

 

Share this post


Link to post
Share on other sites
GibsonRSA

Hi guys,

So after my bug report a while ago, I thought I'd share the response I got from BSG support. I've tried everything exactly as they said and I'm still getting the same error but maybe it helps for some of you.

"Please, reboot your router and check if you do not using VPN service

You need to set full rights for the current user (folder properties, "Security" tab) for the game folder and for the launcher folder. Also temporarily turn off all antivirus and security programs, such as Windows Defender or whitelist launcher and game folder in exceptions list(s).

The following is recommended to solve your problem:
-Install all Windows updates (A licensed version of Windows is required)
-Install VC++ Redistributable 2017 x64 https://go.microsoft.com/fwlink/?LinkId=746572
-If all previous attempts to resolve the problem were unsuccessful, attempt to upgrade your Operating System (OS) to Windows 10. Also ensure that all updates are installed for the new OS.

Quit the game. Delete everything in "BSGlauncher/temp" and in "EFT/cache" folder and then find the folder on your computer %temp% and remove everything from there altogether (if something is not deleted, then just skip it removal). Restart launcher "as administrator" and if problem still persist then you will need to reinstall the game."

Hope you get yours resolved.

Share this post


Link to post
Share on other sites
GibsonRSA
On 11/18/2018 at 12:18 AM, Forien said:
  1. Probably should have try that (and to be 100% sure, disable all antivirus software during installation, as some low-end AV software can mess things up)
  2. no idea
  3. try setting it to auto?

Also, try posting bug report, because no idea how much help you will get from us here on forums. 

Hi Forien, 

Thank you for your suggestions.

  1. I did try reinstall but din't disable the antivirus before hand, so I'll try with that.
  2. I haven't done Windows reinstall, that's an absolute last resort.
  3. It defaults to auto anyway. I saw on another thread that people connected to another server and it worked so I wanted to try that out.

I've posted a bug report and posted the response from BSG on this thread.

All this is making me feel rather empty inside.

 

Share this post


Link to post
Share on other sites
NetriscA

Hi, since the new update i have exactly the same problem as you... :(

I've tried everything but nothing change -_-

  • Sad 1

Share this post


Link to post
Share on other sites
MinmatarCitizen

If any of you guys figure it out, please let us know. This is getting quite annoying.

Thanks in advance and happy hunting!

Share this post


Link to post
Share on other sites
CaptUlmar

 

I have the same problem. I tried everything including the windows reinstall, and nothing helped. I think it is in my case the internet provider's fault.

Share this post


Link to post
Share on other sites
CaptUlmar
Posted (edited)

 

I know what causes this problem for me, namely, I mean the provider, when I use my internet the error occurs every so I decided to switch to the data transmission from the phone. To my surprise, the anti cheat has disappeared. For one more attempt I logged in on the computer of a friend who has access to the optical fiber and, as you can guess, it worked without a problem. In conclusion, I would suggest you how you can change the operator or use data transmission. I hope I helped someone :)

Edited by CaptUlmar

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...
b38e7c858218a416ef714554dce933a2